środa, 21 listopada 2018

Problemy z komentarzami

Od mniej więcej dwóch-trzech tygodni obserwuję na moich blogach problemy z komentowaniem. Objawiają się tym, że wpisujemy komentarz, publikujemy go, a on... znika. Czy może precyzyjniej: nie pojawia się pod postem.

Zrazu myślałem, że to tylko mój lokalny problem, ale dostałem też sygnał od Grażyny, że "wcięło" jej komentarz - być może Wam też się to zdarzyło?

Moje rozpoznanie jest takie, że z jakiegoś powodu kontrolka komentarzy BlogSpota niepoprawnie rozpoznaje fakt zalogowania do konta Google. W przeglądarce "chromowej", z której nie mogę dodawać komentarzy (wszystkie znikają), kontrolka wygląda tak:

Ale już w Operze wygląda jak poniżej i komentarze dodają się aż miło:

Jak widać, w drugim przypadku kontrolka "widzi", że jestem zalogowany - w pierwszym zachowuje się, jakbym był wylogowany (jednak w przypadku wylogowania powinna pojawić się formatka logowania do konta Google'a, a się nie pojawia).

Zrazu myślałem, że to pewnie pamięć podręczna i ciasteczka w przeglądarce, ale zainstalowałem jeszcze trzecią przeglądarkę, Brave i ona od razu po instalacji nie odnotowuje faktu zalogowania do konta Google'a, nawet jeśli loguję się i wylogowuję na przemian.

Szukałem na różnych forach, generalnie problem jest chyba tylko lokalnie na moim blogu, bo nigdzie nie natknąłem się na świeże posty dotyczące komentowania. Napisałem do Google'a, może coś doradzą, chociaż spodziewam się rady w rodzaju "wyczyść pamięć podręczną i ciasteczka", "przeinstaluj przeglądarkę", "użyj najnowszej wersji Chrome'a"...

ROZWIĄZANIE: dostałem odpowiedź od Google'a i bez zaskoczenia: czyścić, przeinstalowywać. Ale sam też zacząłem węszyć - i wywęszyłem, przynajmniej częściowo. Winne wydają się rzeczywiście "ciasteczka" w przeglądarce. Najpierw w Brave wyłączyłem filtr antyspamowy i antyreklamowy - kontrolka komentarza nagle zaczęła widzieć "zalogowane" konto i umożliwiać dodanie komentarzy. Podobnie chciałem zrobić w Vivaldim, ale tutaj nie pomogło ani wyłączenie filtra antyreklamowego, ani przelogowanie na koncie Google'a. Węszyłem jednak dalej i po wejściu w ustawienia przeglądarki odszukałem na karcie prywatności zapamiętane hasło do Gmaila, po czy usunąłem je. Teraz, po ponownym zalogowaniu, wszystko działa. Uf!...

Podsumowując zatem, winne są google'owe "ciasteczka", które zapamiętują stan zalogowania do konta - coś się musiało zmienić w ich budowie czy sposobie odczytywania i przestały działać. Pomaga usunięcie ich z pamięci przeglądarki i usunięcie zapamiętanego hasła (pewnie zadziała też zmiana hasła do konta).

2 komentarze:

  1. Odpukać, ja nie mam dotąd takich problemów, ale chciałam zapytać w sprawie pierwszego obrazu kontrolki w Chromie. Czy w ogóle wybierałeś z rozwijanej listy właściwy profil (Google), czy wybór nic nie powodował?
    Wydaje mi się, że ja także widuję/widywałam taki właśnie stan pola komentarzy (korzystam ze Slimjet), ale jako kompletnie nietechniczna, nie zwracałam na to uwagi i (chyba) wybierałam swój profil z listy. Być może nawet sie to zapamiętywało.

    OdpowiedzUsuń
  2. Wybierałem, ale ta akurat pozycja ma dwa warianty: jeśli jest się zalogowanym do konta Google'a, to wyświetla się nazwa konta i dopisek (Google), a jeśli nie, to tylko "Konto Google". W tym drugim wypadku (brak zalogowania) przy próbie publikacji najpierw wyświetli się okno logowania do Google'a, a dopiero później będzie można dodać komentarz. Tutaj działało mi tak, że kontrolka nie widziała zalogowania, ale też nie przekierowywała do strony logowania, co skutkowało utratą komentarza.

    OdpowiedzUsuń